O - Zjnu Stadium

Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input

There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output

For every case: 
Output R, represents the number of incorrect request.
 

Sample Input

10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output

2

Hint

#include<stdio.h>
const int  N=50005;
int d[N],seat[N];
int n,count;
int find(int x)
{
	if(x==d[x])  return x;
	int t=d[x];
	d[x]=find(d[x]);
	seat[x]+=seat[t];         //seat表示點的位置 
	return d[x];
}
void merge(int x,int y,int z)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy) 
	{
		seat[fy]=seat[x]+z+seat[fy]-seat[y];  // 
		d[fy]=fx;
	}
	else if(seat[y]!=seat[x]+z)
	   count++;
}
int main()
{
	int a,b,c,m;
	while(~scanf("%d%d",&n,&m))
	{
		count=0;
		for(int i=1;i<=n;i++)
		{
			d[i]=i;
			seat[i]=0;
		}
		while(m--)
		{
			scanf("%d%d%d",&a,&b,&c);
			merge(a,b,c);
		}
		printf("%d\n",count);
	}
	
	
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章