E - 貪心

貪心

題目描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Iutput

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500


思路:

貪心策略:先按照價值/代價的比值來排序,肯定是先買比值大的;


代碼

#include <cstdio>
#include<algorithm>
using namespace std;
struct Node{
   double J;
   double F;
   double bi;
}result[10000];

bool cmp(Node a,Node b){
    return a.bi<b.bi;
}
int main(){
   int m,n,i;
   double re;//表示有m磅貓食,n個房間
   while(scanf("%d%d",&m,&n)&&m!=-1&&n!=-1){
      re=0;
      for(i=0;i<n;i++){
         scanf("%lf%lf",&result[i].J,&result[i].F);
         //將J和F的比值錄入
         result[i].bi=result[i].J/result[i].F;
      }
      sort(result,result+n,cmp);
      for(i=n-1;i>=0;i--){
          if(m>=result[i].F){
              m-=result[i].F;
              re+=result[i].J;
          }else{
              re+=m*result[i].bi;
              break;
          }
      }
      printf("%.3lf\n",re);
   }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章