POJ 3041 Asteroids

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20318 Accepted: 11021

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.  Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.  * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

[Submit]   [Go Back]   [Status]   [Discuss]

Home Page   Go Back  To top


	題目是a掉了,但是很多地方還是不大明白,關於二分圖有太大的疑問,今天查了一晚的百度,終於有所收穫。。
	先是二分圖的定義,二分圖顧名思義也是圖的一種,也就是離散上學的G(S,V)(S代表點集,V代表邊集)的一種,二分圖的定義則是:如果頂點V可分割爲兩個互不相交的子集(A,B),並且圖中的每條邊(i,j)所關聯的兩個頂點i和j分別屬於這兩個不同的頂點集(i in A,j in B),則稱圖G爲一個二分圖:
      								
		然後是最大匹配的定義,匹配的意思是任意兩條邊都不依附於一個定點的邊集,如上圖中邊集{(1,5),(2,7)}是一個匹配,而{(1,5),(2,7),(2.5)}則不是,上圖的最大匹配之一可爲爲{(1,5),(2,7),(3,4)}.
		
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int n, k;
bool map[500+5][500+5], vis[10000+5];
int match[500+5];
bool find(int x) {
    for(int i=1;i<=n;i++) {
        if(map[x][i]&&!vis[i]) {
            vis[i]=1;
            if(match[i]==0||find(match[i])) {
                match[i]=x;
                return true;
            }
        }
    }
    return false;
}
int main()
{
    scanf("%d %d", &n, &k);
    memset(map,0,sizeof(map));
    memset(match,0,sizeof(match));
    for(int i=1;i<=k;i++) {
        int x, y;
        scanf("%d %d", &x, &y);
        map[x][y]=1;
    }
    int ans=0;
    for(int i=1;i<=n;i++) {
        memset(vis,0,sizeof(vis));
        if(find(i)) ans++;
    }
    printf("%d\n", ans);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章