NEW RDSP MODE I (找規律)

NEW RDSP MODE I

Time limit    1000 ms               Memory limit        131072 kB

Little A has became fascinated with the game Dota recently, but he is not a good player. In all the modes, the rdsp Mode is popular on online, in this mode, little A always loses games if he gets strange heroes, because, the heroes are distributed randomly.


Little A wants to win the game, so he cracks the code of the rdsp mode with his talent on programming. The following description is about the rdsp mode:


There are N heroes in the game, and they all have a unique number between 1 and N. At the beginning of game, all heroes will be sorted by the number in ascending order. So, all heroes form a sequence One.


These heroes will be operated by the following stages M times:


1.Get out the heroes in odd position of sequence One to form a new sequence Two;


2.Let the remaining heroes in even position to form a new sequence Three;


3.Add the sequence Two to the back of sequence Three to form a new sequence One.


After M times' operation, the X heroes in the front of new sequence One will be chosen to be Little A's heroes. The problem for you is to tell little A the numbers of his heroes.




Input
There are several test cases.
Each case contains three integers N (1<=N<1,000,000), M (1<=M<100,000,000), X(1<=X<=20).
Proceed to the end of file.
Output
For each test case, output X integers indicate the number of heroes. There is a space between two numbers. The output of one test case occupied exactly one line.
Sample Input
5 1 2
5 2 2
Sample Output
2 4
4 3
Hint
In case two: N=5,M=2,X=2,the initial sequence One is 1,2,3,4,5.After the first operation, the sequence One
is 2,4,1,3,5. After the second operation, the sequence One is 4,3,2,1,5.So,output 4 3.



題解:給你三個數字,N,M,X。求1至N個數字經過M次變幻之後前X個數字……

變幻:奇數位置的數放在偶數位置的數的後面……


思路:抓住一個點,模擬後面各次變幻的位置,很容易就找到規律的……


#include<cstdio>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdlib.h>
#include<time.h>
#include<string>
#include<math.h>
#include<map>
#include<queue>
#include<stack>
#define INF 0x3f3f3f3f
#define ll __int64
#define For(i,a,b) for(int i=a;i<b;i++)
#define sf(a)  scanf("%d",&a)
#define sfs(a)  scanf("%s",a)
#define sff(a,b)  scanf("%d%d",&a,&b)
#define sfff(a,b,c) scanf("%lld%lld%lld",&a,&b,&c)
#define pf(a) printf("%d\n",a)
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
ll fun(ll x,ll y)
{
    ll r=1,base=2;
    while(x)
    {
        if(x&1)r=(r*base)%y;
        base=(base*base)%y;
        x/=2;
    }
    return r;
}
int main()
{
    ll a,b,c;
    while(~scanf("%I64d%I64d%I64d",&a,&b,&c))
    {
        if(a%2==0)a++;
        ll temp=fun(b,a);
        printf("%I64d",temp);
        ll num=temp;
        For(i,2,c+1)
        {
            num+=temp;
            num%=a;
            printf(" %I64d",num);
        }
        printf("\n");
    }
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章