poj 2141

 

Message Decowding
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10878   Accepted: 6016

Description

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
        yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

Input

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming

Source

 
 
 
#include<iostream> 
#include<ctype.h> 
#include<cstdio> 
using namespace std;
   int main(){
     char S[26];
     char C[100]={'0'};
     for(int i= 0; i<=25; i++){
         cin>>S[i];
     }
     int j=0;
     while(scanf("%c",&C[j])!=EOF){
         if(C[j]==32){
             cout<<' ';
         }
         else if((C[j]>='A')&&(C[j]<='Z')){
             char index=tolower(C[j]);
             int x=index - 'a';
             index = toupper(S[x]);
             cout<<index;
         }
         else if((C[j]>='a')&&(C[j]<='z')){
             int x;
             x=C[j] - 'a';
             cout<<S[x];
         }
         j++;
     } 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章