poj 1844 數學問題

Sum
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 9591   Accepted: 6281

Description

Consider the natural numbers from 1 to N. By associating to each number a sign (+ or -) and calculating the value of this expression we obtain a sum S. The problem is to determine for a given sum S the minimum number N for which we can obtain S by associating signs for all numbers between 1 to N.

For a given S, find out the minimum value N in order to obtain S according to the conditions of the problem.

Input

The only line contains in the first line a positive integer S (0< S <= 100000) which represents the sum to be obtained.

Output

The output will contain the minimum number N for which the sum S can be obtained.

Sample Input

12

Sample Output

7

Hint

The sum 12 can be obtained from at least 7 terms in the following way: 12 = -1+2+3+4+5+6-7.

Source

 
本題可以理解爲數學問題,我們首先不嘗試減號的情況,設輸入數據爲s 如果s可以恰巧等於1……n這n個數累加的和sum ,我們可以直接輸出n
否則,sum一定會大於s,此時,如果(sum-s)爲偶數,我們就可以在1……n這n個數中找到兩個和爲(sum-s)/2 的數字 ,把他們改成減號,就相當於在sum中減去了(sum-s),問題解決.
 
#include<iostream>
using namespace std;
int main()
{
	int sum=0,s,n=0;
	cin>>s;
	while(sum<s||(sum-s)%2==1){
		n++;
		sum+=n;
	}
	cout<<n;
	return 0;
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章