poj 1163

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 32155   Accepted: 19016

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

 
在discuss裏看到以下代碼,不錯的思想,可以AC
#include<stdio.h>
#define M 110
#define max(a,b) a>b?a:b
int dp[M][M];
int main(){
	int n;
	scanf("%d",&n);
	for(int i=1; i<=n; i++){
//		getchar();
		for(int j=1; j<=i; j++){
			scanf("%d",&dp[i][j]);
		}
	}
	for(int i=n-1; i>=1; i--){
		for(int j=1; j<=i; j++){
			dp[i][j] += max(dp[i+1][j],dp[i+1][j+1]);
		}
	}
	printf("%d\n",dp[1][1]);
	return 1;	
}


 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章