樹形dp入門(poj 2342 Anniversary party)

題意:
某公司要舉辦一次晚會,但是爲了使得晚會的氣氛更加活躍,每個參加晚會的人都不希望在晚會中見到他的直接上司,現在已知每個人的活躍指數和上司關係(當然不可能存在環),求邀請哪些人(多少人)來能使得晚會的總活躍指數最大。
解題思路:
任何一個點的取捨可以看作一種決策,那麼狀態就是在某個點取的時候或者不取的時候,以他爲根的子樹能有的最大活躍總值。分別可以用f[i,1]和f[i,0]表示第i個人來和不來。
當i來的時候,dp[i][1] += dp[j][0];//j爲i的下屬
當i不來的時候,dp[i][0] +=max(dp[j][1],dp[j][0]);//j爲i的下屬

Description

There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests’ conviviality ratings.
Input

Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go N – 1 lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
Output

Output should contain the maximal sum of guests’ ratings.
Sample Input

7
1
1
1
1
1
1
1
1 3
2 3
6 4
7 4
4 5
3 5
0 0
Sample Output

5

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL數值算法頭文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板類頭文件
using namespace std;

typedef long long ll;
const int maxn=6005;
const int INF=0x3f3f3f3f;

//先建樹,找到根節點,然後開始dfs
int n,m,x,y;
int dp[maxn][2],vis[maxn],father[maxn];//dp[i][1]表示來,dp[i][0]表示不來

void dfs(int node)
{
    int i,j;
    vis[node]=1;
    for(i=1; i<=n; i++)
    {
        if(!vis[i]&&father[i]==node)
        {
            dfs(i);//從根節點的兒子節點開始遞歸
            dp[node][1]+=dp[i][0];//上司來
            dp[node][0]+=max(dp[i][1],dp[i][0]);//上司不來,然後看下屬來還是不來
        }
    }
}

int main()
{
    while(~scanf("%d",&n))
    {
        int i,j;
        memset(father,0,sizeof(father));
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        for(i=1; i<=n; i++)
            scanf("%d",&dp[i][1]);
        int root=0;
        //bool flag=1;
        while(~scanf("%d %d",&x,&y)&&(x!=0||y!=0))
        {
            father[x]=y;
            //if(root==x||flag)
            //root=y;
        }
        root=y;
        while(father[root])
            root=father[root];//找根節點
        dfs(root);
        int maxx=max(dp[root][1],dp[root][0]);
        printf("%d\n",maxx);
    }
    return 0;
}

//更快的一種方法
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL數值算法頭文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板類頭文件
using namespace std;

//typedef long long ll;
//const int maxn=6005;
//const int INF=0x3f3f3f3f;

struct node
{
    int child,father,brother,present,not_present;
    int max()//結構體內的函數調用時耗時少
    {
        return present>not_present?present:not_present;
    }
    void init()
    {
        child=father=brother=not_present=0;
    }
} tree[6005];

void dfs(int root)
{
    int son = tree[root].child;
    while(son)
    {
        dfs(son);
        tree[root].present+=tree[son].not_present;
        tree[root].not_present+=tree[son].max();
        son = tree[son].brother;
    }
}

int main()
{
    int n,i,j,k,l;
    while(~scanf("%d",&n)&&n)
    {
        for(i = 1; i<=n; i++)
        {
            scanf("%d",&tree[i].present);
            tree[i].init();
        }
        while(~scanf("%d%d",&l,&k),l+k)
        {
            tree[l].father = k;
            tree[l].brother = tree[k].child;
            tree[k].child = l;
        }
        for(i = 1; i<=n; i++)
        {
            if(!tree[i].father)
            {
                dfs(i);
                printf("%d\n",tree[i].max());
                break;
            }
        }
    }

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章