hdu 1011(Starship Troopers,樹形dp)

                            Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)
Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19362
Accepted Submission(s): 5130

Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern’s structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers – the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1’s.

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input
5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1

Sample Output
50
7

#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<math.h>
#include<cstdio>
#include<sstream>
#include<numeric>//STL數值算法頭文件
#include<stdlib.h>
#include <ctype.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#include<functional>//模板類頭文件
using namespace std;

typedef long long ll;
const int maxn=500;//之前很多把wa都是數組開的太小了
const int INF=0x3f3f3f3f;

int x,y,n,m,id;
int dp[maxn][maxn],bug[maxn],p[maxn],vis[maxn],head[maxn];

struct node
{
    int now,next;
} tree[maxn];

int add_edgree(int x,int y)
{
    tree[id].now=y;
    tree[id].next=head[x];
    head[x]=id++;
}

void dfs(int root)
{
    int cost,i,j,k,son;
    vis[root]=1;
    cost=(bug[root]+19)/20;
    for(i=cost; i<=m; i++)
        dp[root][i]=p[root];//從root結點到下一個節點能得到p[root]
    for(i=head[root]; i!=-1; i=tree[i].next)
    {
        son=tree[i].now;
        if(!vis[son])
        {
            dfs(son);//從son結點遍歷其子樹
            for(j=m; j>=cost; j--)//類似於01揹包
            {
                for(k=1; j+k<=m; k++)//從root到son需要j,son需要k
                    if(dp[son][k])
                        dp[root][j+k]=max(dp[root][j+k],dp[root][j]+dp[son][k]);
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&n,&m)&&(n!=-1||m!=-1))
    {
        id=0;
        memset(dp,0,sizeof(dp));
        memset(vis,0,sizeof(vis));
        memset(bug,0,sizeof(bug));
        memset(p,0,sizeof(p));
        memset(head,-1,sizeof(head));
        for(int i=1; i<=n; i++)
            scanf("%d %d",&bug[i],&p[i]);
        for(int i=1; i<n; i++)
        {
            scanf("%d %d",&x,&y);
            add_edgree(x,y);//建樹
            add_edgree(y,x);
        }
        if(!m)
        {
            printf("0\n");
            continue;
        }
        dfs(1);
        printf("%d\n",dp[1][m]);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章