HDU 4639 Hehe

Hehe

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 48    Accepted Submission(s): 36


Problem Description
As we all know, Fat Brother likes MeiZi every much, he always find some topic to talk with her. But as Fat Brother is so low profile that no one knows he is a rich-two-generation expect the author, MeiZi always rejects him by typing “hehe” (wqnmlgb). You have to believe that there is still some idealized person just like Fat Brother. They think that the meaning of “hehe” is just “hehe”, such like “hihi”, “haha” and so on. But indeed sometimes “hehe” may really means “hehe”. Now you are given a sentence, every “hehe” in this sentence can replace by “wqnmlgb” or just “hehe”, please calculate that how many different meaning of this sentence may be. Note that “wqnmlgb” means “我去年買了個表” in Chinese.
 

Input
The first line contains only one integer T, which is the number of test cases.Each test case contains a string means the given sentence. Note that the given sentence just consists of lowercase letters.
T<=100
The length of each sentence <= 10086
 

Output
For each test case, output the case number first, and then output the number of the different meaning of this sentence may be. Since this number may be quite large, you should output the answer modulo 10007.
 

Sample Input
4 wanshangniyoukongme womenyiqichuqukanxingxingba bulehehewohaiyoushi eheheheh
 

Sample Output
Case 1: 1 Case 2: 1 Case 3: 2 Case 4: 3
 

Source
 

Recommend
zhuyuanchen520
 
題意:一個“hehe" 可以表示兩種意思。 問一句話有多少種意思。

思路: 斐波那契數列
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;

//斐波那契數列

const int V = 5050 + 50;
const int MaxN = 500 + 5;
const int mod = 10000 + 7;
int T, ans, num[V];
char ch[10100];
int main() {
    int i, j, k;
    scanf("%d", &T);
    num[0] = num[1] = 1;
    for(i = 2; i <= V; ++i)
        num[i] = (num[i - 1] + num[i - 2]) % mod;
    for(i = 1; i <= T; ++i) {
        ans = 1;
        int sum = 0;
        scanf("%s", &ch);
        int len = strlen(ch);
        for(j = 1; j < len; ++j) {
            if(ch[j] == 'e' && ch[j - 1] == 'h') {
                sum++;
                j++;
            }
            else {
                ans = (ans * num[sum]) % mod;
                sum = 0;
            }
        }
        ans = (ans * num[sum]) % mod;
        printf("Case %d: %d\n", i, ans);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章