hdu1714RedField 橢圓扇形面積公式

RedField

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1118    Accepted Submission(s): 413


Problem Description
As the graph you see below, we named the red part "RedField".The read part is the intersection of an ellipse and a triangle.Now, 8600's not good at math, so he wants you to help him calculate the area of the "RedField".
 

Input
The first line of input contains n, the number of test cases. n lines follow.Each test case contains four numbers a, b, x, y(0 < b <= a <= x),and a is the lenth of OA, b is the lenth of OB,and x, y representing the coordinate of the point P.
 

Output
For each test case, output the area of the "RedField",accurate up to 2 decimal places.
 

Sample Input
1 1.00 1.00 2.00 2.00
 

Sample Output
0.39
 

Source


重點就是一個扇形公式。
#include<stdio.h>
#include<cmath>
#include<iostream>
using namespace std;
struct epllies
{
    double a,b;
}p;
struct point
{
    double x,y;
}q;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        double k,X1,Y1,S,m,n;
        scanf("%lf %lf %lf %lf",&p.a,&p.b,&q.x,&q.y);
        k=q.y/q.x;
        X1=sqrt((p.a*p.a*p.b*p.b)/(p.b*p.b+p.a*p.a*k*k));

        S=(p.a*p.b*acos(X1/p.a))/2;      ///橢圓扇形 S=(a*b*arccos(x/a))/2

        printf("%.2lf\n",S);
    }
}

 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章