ZOJ1986 Bridging Signals onlogn複雜度求LIS

Bridging Signals

Time Limit: 2 Seconds      Memory Limit: 65536 KB

'Oh no, they've done it again', cries the chief designer at the Waferland chip factory. Once more the routing designers have screwed up completely, making the signals on the chip connecting the ports of two functional blocks cross each other all over the place. At this late stage of the process, it is too expensive to redo the routing. Instead, the engineers have to bridge the signals, using the third dimension, so that no two signals cross. However, bridging is a complicated operation, and thus it is desirable to bridge as few signals as possible. The call for a computer program that finds the maximum number of signals which may be connected on the silicon surface without crossing each other, is imminent. Bearing in mind that there may be thousands of signal ports at the boundary of a functional block, the problem asks quite a lot of the programmer. Are you up to the task?

Figure 1. To the left: The two blocks' ports and their signal mapping (4, 2, 6, 3, 1, 5). To the right: At most three signals may be routed on the silicon surface without crossing each other. The dashed signals must be bridged.

A typical situation is schematically depicted in figure 1. The ports of the two functional blocks are numbered from 1 to p, from top to bottom. The signal mapping is described by a permutation of the numbers 1 to p in the form of a list of p unique numbers in the range 1 to p, in which the ith number specifies which port on the right side should be connected to the ith port on the left side. Two signals cross if and only if the straight lines connecting the two ports of each pair do.


Input

On the first line of the input, there is a single positive integer n, telling the number of test scenarios to follow. Each test scenario begins with a line containing a single positive integer p < 40000, the number of ports on the two functional blocks. Then follow p lines, describing the signal mapping:

On the ith line is the port number of the block on the right side which should be connected to the ith port of the block on the left side.


Output

For each test scenario, output one line containing the maximum number of signals which may be routed on the silicon surface without crossing each other.


Sample Input

4
6
4
2
6
3
1
5
10
2
3
4
5
6
7
8
9
10
1
8
8
7
6
5
4
3
2
1
9
5
8
9
2
3
1
7
4
6


Sample Output

3
9
1
4


Source: Northwestern Europe 2003


題意:題意是說去掉幾根線後,使得剩下不相交的線數量最多,問剩下最多的線的條數

思路:對於右邊而言,不交叉就意味着序號是嚴格遞增的,那麼嚴格遞增的最大數量是多少?這樣想的話可以轉化成求LIS,即最長上升子序列。然後看一看數據範圍,發現最大隻能承受onlogn的複雜度,於是可以使用二分。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>

using namespace std;

int a[40009];
int b[40009];

int find(int len,int x)
{
	int i=1,j=len;
	
	while(i<=j)
	{
		int mid=(i+j)/2;
		if(b[mid]>x)
		   j=mid-1;
		   else
		   i=mid+1;
	}
	return i;
}

int main()
{
	int T,n;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++)
		scanf("%d",&a[i]);
		
		int j=1;
		b[1]=a[1];
		
		for(int i=2;i<=n;i++)
		{
			if(b[j]<a[i])
			b[++j]=a[i];
			else
			{
				int k=find(j,a[i]);//求出第一個大於a[i]的數字,然後用a[i]去替換掉
				b[k]=a[i];
			}
		}
		
		printf("%d\n",j);
		
		
	} 
	return 0;
} 








發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章