POJ3279 Fliptile

Fliptile
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6336   Accepted: 2410

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

題意:1表示黑麪,0表示白麪,要把所有的黑麪變成白麪,翻轉某一塊,可以使它周圍四塊都翻轉。如果能使得最終都爲白色就輸出最小的翻轉步數,如果不能滿足就輸出IMPOSSIBLE。

思路:如果一一枚舉,複雜度就是2^(n*m),然後可以通過二進制枚舉的方式來降低複雜度。枚舉第一行(1<<n)種情況(每個位置翻轉或不翻轉),從第二行開始,每次討論它的上一行同列位置是否爲黑色,如果是黑色那麼當前位置一定要翻轉。


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;

int m,n;
int a[20][20];
int flag;
int ans[20][20],flip[20][20];
int dis[5][2]={0,0,0,1,0,-1,1,0,-1,0};

int check(int x,int y)  //判斷當前這個位置是否爲黑色 
{
	int tmp=a[x][y];
	for(int i=0;i<5;i++)
	{
		int xx=x+dis[i][0];
		int yy=y+dis[i][1];
		
		if(xx<0 || xx>=m || yy<0 || yy>=n) continue;
		
		tmp+=flip[xx][yy];
	}
	tmp=tmp&1;    //判斷奇偶性 ,奇數則表示爲黑色1 
	return tmp;
}

int fun()
{
	for(int i=1;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(check(i-1,j))//對於當前位置(i,j),每次判斷(i-1,j)的位置是不是爲白色0 
			flip[i][j]=1; //不是則要翻轉 
		}
	}
	
	for(int i=0;i<n;i++)
	{
		if(check(m-1,i))//判斷下最後一行是不是都爲白色0 
		return 9999999;
	}
	
	int num=0;
	for(int i=0;i<m;i++)
	{
		for(int j=0;j<n;j++)
		{
			num+=flip[i][j];
		}
	}
	return num;
}

int main()
{
	while(~scanf("%d%d",&m,&n))
	{
		for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
			{
				scanf("%d",&a[i][j]);
			}
		
		memset(ans,0,sizeof ans);
		
		flag=0;
		int tmp=999999;
		int res;
		
		for(int i=0;i<(1<<n);i++)
		{
			memset(flip,0,sizeof flip);
			
			for(int j=0;j<n;j++)
			flip[0][j]=(i>>j)&1; //判斷枚舉的第j個位置是否進行翻轉操作 
			
			res=fun();
			if(res<tmp)  //求最小值 
			{
				tmp=res;
				for(int j=0;j<m;j++)
				for(int k=0;k<n;k++)
				ans[j][k]=flip[j][k];
			}
		}
		
		
		if(tmp==999999)
		puts("IMPOSSIBLE");
		else
		{
			for(int i=0;i<m;i++)
			for(int j=0;j<n;j++)
				printf("%d%c",ans[i][j],j==n-1?'\n':' ');
		}
		
	}	
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章