POJ 3601:Tower of Hanoi

Tower of Hanoi
Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 1903   Accepted: 651

Description

The Tower of Hanoi is a puzzle consisting of three pegs and a number of disks of different sizes which can slide onto any peg. The puzzle starts with the disks neatly stacked in order of size on one peg, the smallest at the top, thus making a conical shape. The objective of the puzzle is to move the entire stack to another peg, obeying the following rules:

  • Only one disk may be moved at a time.
  • Each move consists of taking the upper disk from one of the pegs and sliding it onto another peg, on top of the other disks that may already be present on that peg.
  • No disk may be placed on top of a smaller disk.

For n disks, it is a well-known result that the optimal solution takes 2n − 1 moves.

To complicate the puzzle a little, we allow multiple disks to be of the same size. Moreover, equisized disks are mutually distinguishable. Their ordering at the beginning should be preserved at the end, though it may be disturbed during the process of solving the puzzle.

Given the number of disks of each size, compute the number of moves that the optimal solution takes.

Input

The input contains multiple test cases. Each test case consists of two lines. The first line contains two integers n and m (1 ≤ n ≤ 100, 1 ≤ m ≤ 106). The second lines contains n integers a1a2, …, an (1 ≤ a1,a2, …, an ≤ 105). For each 1 ≤ i ≤ n, there are ai disks of size i. The input ends where EOF is met.

Output

For each test case, print the answer modulo m on a separate line.

Sample Input

1 1000
2
5 1000
1 1 1 1 1
5 1000
2 2 2 2 2
5 1000
1 2 1 2 1

Sample Output

3
31
123
41

Source


題意還是求漢諾塔的最少挪動次數,不同的是這次有相同大小的盤子了。

當第k大盤子只有一個的時候很好辦,想象一下,相同大小的盤子當成一個盤子,放一次放倒了,經過這一次,正好放正回來了。

當第k大盤子有多個的時候,挪動的時候假設k-1個盤子在柱子上已經放好了,那麼相同大小的盤子要順序一致,必須騰出兩個柱子來挪,這部分是2*val[k],之前的那k-1個盤子再都使用當成一個盤子的方法,顛一次倒一次,正好放正了。

代碼:

#pragma warning(disable:4996)
#include <iostream>
#include <functional>
#include <algorithm>
#include <cstring>
#include <vector>
#include <string>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <deque>
#include <set>
#include <map>
using namespace std;
typedef long long ll;

#define eps 1e-8 
#define INF 1<<25 
#define repp(i, n, m) for (int i = n; i <= m; i++)
#define rep(i, n, m) for (int i = n; i < m; i++)
#define sa(n) scanf("%d", &(n))
#define mp make_pair
#define ff first
#define ss second
#define pb push_back

const int maxn = 1e5 + 5;
const ll mod = 1e9 + 7;
const double PI = acos(-1.0);

int n, m;
int val[maxn], cnt[maxn], dp[maxn];

void solve()
{
	int i, j, k;
	repp(i, 1, n)
	{
		sa(val[i]);
	}
	repp(i, 1, n)
	{
		cnt[i] = ((cnt[i - 1] << 1) + val[i]) % m;
	}
	dp[1] = 2 * val[1] - 1;
	repp(i, 2, n)
	{
		if (val[i] == 1)
		{
			dp[i] = cnt[i];
		}
		else
		{
			dp[i] = (2 * cnt[i - 1] + 2 * val[i] + dp[i - 1]) % m;
		}
	}
	printf("%d\n", dp[n]);
}

int main()
{
#ifndef ONLINE_JUDGE  
	freopen("i.txt", "r", stdin);
	freopen("o.txt", "w", stdout);
#endif
	while (scanf("%d%d", &n, &m) != EOF)
	{
		solve();
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章