課程練習一Problem M

Problem Description
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be only of theoretical interest. 
This problem involves the efficient computation of integer roots of numbers. 
Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power, for an integer k (this integer is what your program must find).
 

Input
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10<sup>101</sup> and there exists an integer k, 1<=k<=10<sup>9</sup> such that k<sup>n</sup> = p.
 

Output
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.
 

Sample Input
2 16 3 27 7 4357186184021382204544
 

Sample Output
4 3 1234

 

題意: 輸入n,p; 求k 並且滿足k的n次方等於p

思路: 直接定義double型用pow()函數,就ok了

個人感覺這題是想考 大數乘法或者快速乘法的,只是這道題可以用函數 水過。


代碼:

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
double n,p;
while(cin>>n>>p)

   double m=1.0/n; 
        cout<<pow(p,m)<<endl;  
    }  
system("pause");
return 0;

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章