課程練習一-Problem Q

Problem Description
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

Input
* Line 1: A single integer N <br> <br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

Output
* Line 1: A single integer that is the median milk output.
 

Sample Input
5 2 4 1 3 5
 

Sample Output
3
 
題意: 就是求一串數中中間大小的數

思路:將數存到數組中,排下序,取數組下標中間的數就是了。

代碼:
#include<iostream>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
int N;
cin>>N;
int a[10001];
memset(a,0,sizeof(a));
for(int i=0;i<N;i++)
{
cin>>a[i];
}
sort(a,a+N);
int m=(N)/2;
cout<<a[m]<<endl;
system("pause");
return 0;

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章