課程練習二-1013-A strange lift

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 &lt;= Ki &lt;= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button &quot;UP&quot; , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button &quot;DOWN&quot; , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button &quot;UP&quot;, and you'll go up to the 4 th floor,and if you press the button &quot;DOWN&quot;, the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.<br>Here comes the problem: when you is on floor A,and you want to go to floor B,how many times at least he havt to press the button &quot;UP&quot; or &quot;DOWN&quot;?<br>
 

Input
The input consists of several test cases.,Each test case contains two lines.<br>The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.<br>A single 0 indicate the end of the input.
 

Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 

Sample Input
5 1 5<br>3 3 1 2 5<br>0
 

Sample Output
3
 
題意: 電梯每一層有向下、向上兩個按鈕,並且每層電梯只能向上、向下 指定的層數k。
給出電梯層數N,從A層到B層是否可達,若可以輸出按按鈕最少的次數。否則-1.

思路:用結構體記錄當前的位置和能移動的層數,然後直接bfs,
代碼:
#include<iostream>
#include<queue>
#include<string.h>
#include<iostream>
using namespace std;
int ans = 0;
struct lift
{
int location;
int k;
int ans;
};
bool bfs(int A,int B,int N,int a[],int b[])
{
queue<lift>Q;
lift Ls;
Ls.k=a[A];
Ls.ans = 0;
b[A] = 1;
Ls.location = A;
Q.push(Ls);
while (!Q.empty())
{
lift q = Q.front();
Q.pop();
if (q.location == B)
{
ans = q.ans;
return true;
}
lift p;
if (q.location - q.k >= 1 && q.location - q.k<=N)
{
p.location = q.location - q.k;
p.k = a[p.location];
p.ans = q.ans + 1;
if (b[p.location] == 0)
{
Q.push(p);
b[p.location] = 1;
}
}
if (q.location + q.k <= N&&q.location + q.k>=1)
{
p.location = q.location + q.k;
p.k = a[p.location];
if (b[p.location] == 0)
{
p.ans = q.ans + 1;
Q.push(p);
b[p.location] = 1;
}
}
}
return false;
}
int main()
{
int N, A, B;
while (cin >> N)
{
if (N == 0)
break;
cin >> A >> B;
ans = 0;
int a[201];
int b[201];
memset(b, 0, sizeof(b));
memset(a, 0, sizeof(a));
for (int i = 1; i <= N; i++)
{
cin >> a[i];
}
if (bfs(A, B,N, a,b))
{
cout << ans << endl;
}
else cout << -1 << endl;
}
system("pause");
return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章