2016SDAU編程練習二1015

Knight Moves 


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.<br>Of course you know that it is vice versa. So you offer him to write a program that solves the &quot;difficult&quot; part. <br><br>Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. <br>
 


Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. <br>
 


Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". <br>
 


Sample Input
e2 e4<br>a1 b2<br>b2 c3<br>a1 h8<br>a1 h7<br>h8 a1<br>b1 c3<br>f6 f6<br> 


Sample Output
To get from e2 to e4 takes 2 knight moves.<br>To get from a1 to b2 takes 4 knight moves.<br>To get from b2 to c3 takes 2 knight moves.<br>To get from a1 to h8 takes 6 knight moves.<br>To get from a1 to h7 takes 5 knight moves.<br>To get from h8 to a1 takes 6 knight moves.<br>To get from b1 to c3 takes 1 knight moves.<br>To get from f6 to f6 takes 0 knight moves.<br> 


Source

University of Ulm Local Contest 1996


題意:國際象棋騎士,求a到b最短距離

思路:這個也說過,BFS,不越界就行

感想:。。。不想做了。。。

AC代碼:
#include<iostream>
#include<string.h>
#include<queue>
#include<stdio.h>
using namespace std;
int vis[20][20];
string s1,s2;
struct ans
{
    int x;
    int y;
    int ste;
}n1,n2;
int dix[10]={-2,-2,-1,-1,1,1,2,2};
int diy[10]={-1,1,-2,2,-2,2,-1,1};
int ww(int a,int b)
{
    if(a>0&&a<=8&&b>0&&b<=8) return 1;
    return 0;
}
int BFS( )
{
    n1.ste=0;
    queue<ans> Q;
    Q.push(n1);
    while(!Q.empty())
    {
        n1=Q.front();
        Q.pop();
        if(n1.x==s2[1]-'0'&&n1.y==s2[0]-'a'+1) return n1.ste;
        for(int i=0;i<8;i++)
        {
            n2.x=n1.x+dix[i];
            n2.y=n1.y+diy[i];
            if(ww(n2.x,n2.y)&&!vis[n2.x][n2.y])
            {
                vis[n2.x][n2.y]=1;
                n2.ste=n1.ste+1;
                Q.push(n2);
            }
        }
    }
    return -1;
}


int main()
{
    //freopen("a.txt","r",stdin);
    while(cin>>s1>>s2)
    {
        int i,j;
        n1.x=s1[1]-'0';
        n1.y=s1[0]-'a'+1;
        for(i=0;i<20;i++)
            for(j=0;j<20;j++)
             vis[i][j]=0;
        vis[n1.x][n1.y]=1;
        int t=BFS();
            cout<<"To get from "<<s1<<" to "<<s2<<" takes "<<t<<" knight moves."<<endl;
    }
    return 0;
}


 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章