2016SDAU編程練習二1005



Turn the corner 


Problem Description
Mr. West bought a new car! So he is travelling around the city.<br><br>One day he comes to a vertical corner. The street he is currently in has a width x, the street he wants to turn to has a width y. The car has a length l and a width d.<br><br>Can Mr. West go across the corner?<br><img src=../../../data/images/2438-1.jpg><br>
 


Input
Every line has four real numbers, x, y, l and w.<br>Proceed to the end of file.<br>
 


Output
If he can go across the corner, print "yes". Print "no" otherwise.<br>
 


Sample Input
10 6 13.5 4<br>10 6 14.5 4<br> 


Sample Output
yes<br>no<br> 


Source
2008 Asia Harbin Regional Contest Online

 

題意:車轉角問題,讓他能拐過彎道

思路:其實主要是數學問題算公式

感想:相比搜索,二分真是好做多了

AC代碼:

#include <cstdio>
#include<iostream>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<map>
#include<set>
#include<vector>
#include<iomanip>
using namespace std;
double PI=acos(-1.0);
double x,y,v,w;
double s (double a)
{
    return v*cos(a)+(w-x*cos(a))/sin(a);
}
int main()
{
    double r,l,mid,midd;
    while(cin>>x>>y>>v>>w)
    {
        l=0;r=PI/2;
        while(r-l>0.0000001)
        {
            mid=(r+2*l)/3;
            midd=(l+r*2)/3;
            if(s(mid)>s(midd))
                r=midd;
            else
                l=mid;
        }
        if(s(l)>y) cout<<"no"<<endl;
        else cout<<"yes"<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章