2016SDAU編程練習二1018

Tempter of the Bone 




Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.<br><br>The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.<br>
 


Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:<br><br>'X': a block of wall, which the doggie cannot enter; <br>'S': the start point of the doggie; <br>'D': the Door; or<br>'.': an empty block.<br><br>The input is terminated with three 0's. This test case is not to be processed.<br>
 


Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.<br>
 


Sample Input
4 4 5<br>S.X.<br>..X.<br>..XD<br>....<br>3 4 5<br>S.X.<br>..X.<br>...D<br>0 0 0<br> 


Sample Output
NO<br>YES<br> 


Author
ZHANG, Zheng
 


Source
ZJCPC2004

 

題意:在座標系內給起點和終點,問是否能在t時刻到達

思路:DFS,借鑑了別人的,在網上又搜還要剪枝什麼的

感想:感覺搜索題都長得差不多,走來走去走來走去。。。

AC代碼:

#include<iostream>
#include<cstdio>
#include<stdio.h>
#include<cstring>
#include<cmath>
using namespace std;
int n,m,t,ex,ey,tt,falg;
char mapp[10][10];
int tox[5]={0,0,1,-1};
int toy[5]={1,-1,0,0};
void dfs(int x,int y,int num)
{
    if(x<0||y<0||x>=n||y>=m)
        return;
    if(mapp[x][y]=='X')
        return ;
    if(x==ex&&y==ey&&num==t)
        falg=1;
    if(falg)
    {
        tt=num;
        return ;
    }
    int tem=t-fabs(x-ex)-fabs(y-ey)-num;
    if(tem<0||((tem%2)==1))
       return ;
    for(int i=0;i<4;i++)
    {
        mapp[x][y]='X';
        dfs(x+tox[i],y+toy[i],num+1);
        mapp[x][y]='.';
    }


}
int main()
{
   // freopen("r.txt","r",stdin);
    int i,j,sx,sy;
    while(cin>>n>>m>>t)
    {
        if((t+n+m)==0) break;
        int wall=0;
        for(i=0;i<n;i++)
        {
            scanf("%s",mapp[i]);
            for(j=0;j<m;j++)
            {
                if(mapp[i][j]=='S')
                {
                    sx=i;
                    sy=j;
                }
                if(mapp[i][j]=='D')
                {
                    ex=i;
                    ey=j;
                }
                if(mapp[i][j]=='X')
                    wall++;
            }
        }
        if((n*m-wall-1)<t)
        {
            cout<<"NO"<<endl;
            continue;
        }




        falg=0;
        dfs(sx,sy,0);
        if(falg)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;


    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章