Can you find it? ——二分

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
Output
For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
Sample Input
3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10
Sample Output
Case 1:
NO
YES
NO

/*
先保存(數組sum)數組a與數組b的每一個數字分別相加,再二分sum
*/


#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cmath>
using namespace std;
#define ll long long int 
#define ull unsigned long long int 
#define e 2.718281828459
#define INF 0x7fffffff
#pragma warning(disable:4996)
#define pf printf
#define sf scanf
#define max(a,b) (a)>(b)?(a):(b);
#define pi  acos(-1.0);
#define  eps 1e-9;
const int MAX=505;
int sum[MAX*MAX];
int main(void) {
    int a[MAX], b[MAX], c[MAX];
    int L, N, M;
    int S,X;


    int time = 1;
    while (sf("%d %d %d", &L, &N, &M) != EOF) {
        memset(a, 0, sizeof(a));
        memset(b, 0, sizeof(b));
        memset(c, 0, sizeof(c));
        memset(sum, 0, sizeof(sum));

        for (int i = 0; i < L; i++)  sf("%d", &a[i]);
        for (int j = 0; j < N; j++)  sf("%d", &b[j]);
        for (int k = 0; k < M; k++)  sf("%d", &c[k]);

        int len=0;
        for (int i = 0; i < L; i++)
            for (int j = 0; j < N; j++)
                sum[len++] = a[i] + b[j];
        sort(c, c + M);
        sort(sum, sum + len);
        len=unique(sum, sum + len)-sum;//除去重複的數字,計算去重後的長度

        cin >> S;
        cout << "Case " << time++ << ":" << endl;

        while (S--) {
            cin >> X;
            bool judge = false;
            //if (X  > c[M - 1] + sum[len - 1] || X  < c[0] + sum[0])
            //              pf("NO\n"), judge = true;//超出範圍的數字直接判斷
            //  加了就WA爲什麼呢
            for (int i = 0; i < M&&!judge; i++) {
                int find = X - c[i];
                int left = 0, right = len - 1;
                int mid;

                while (right >= left && !judge) {

                    mid = (right + left) / 2;

                    if (sum[mid] > find)
                        right = mid - 1;
                    else if (sum[mid] < find)
                        left = mid + 1;
                    else
                        pf("YES\n"),judge=true;

                }

            }
            if (!judge)
                pf("NO\n");
        }


    }



    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章