HDU 3549 網絡流初步

Flow Problem
Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 12912    Accepted Submission(s): 6154


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.


Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)


Output
For each test cases, you should output the maximum flow from source 1 to sink N.


Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1



Sample Output

Case 1: 1
Case 2: 2

昨天看了一個下午的網絡流,大體上懂了 Ford - Fulkerson 方法的EK算法,拿這題貫通一下

#include <cstdio>
#include <cstring>
#include <queue>
#include <climits>
using namespace std;
#define MAX_V 15*2
#define MAX_E 1000*2

int Pre[MAX_E]; 
bool Visit[MAX_E];
int Map[MAX_E][MAX_E];      
bool BFS(int s,int t,int V,int E)
{
    int cur;
    queue<int> Q;
    memset(Pre,0,sizeof Pre);
    memset(Visit,false,sizeof Visit);
    Visit[s] = true;   Q.push(s);   
    while(!Q.empty())
    {
        cur = Q.front();Q.pop();
        if(cur == t) return true;  
        for(int i=1;i<=V;++i)
        {
            if(!Visit[i] && Map[cur][i]) 
            {
                Q.push(i);
                Pre[i] = cur;
                Visit[i] = true;
            }
        }
    }
    return false;
}
int Max_flow(int s,int t,int V,int E)  
{
    int flow = 0;
    while(true)
    {
        if(!BFS(s,t,V,E)) return flow;  
        int Min = INT_MAX;
        for(int i=t;i!=s;i=Pre[i]) 
            Min = min(Min,Map[Pre[i]][i]);
        for(int i=t;i!=s;i=Pre[i])
        {
            Map[Pre[i]][i] -= Min;  
            Map[i][Pre[i]] += Min;  
        }
        flow += Min;
    }
}
void Handle(int V,int E)
{
    memset(Map,0,sizeof Map);
    for(int i = 1,u,v,c;i <= E;i++) 
    {
        scanf("%d %d %d",&u,&v,&c);
        Map[u][v] += c;              
    }
}
int main(void)
{
  // freopen("F:\\test.txt","r",stdin);
    int T;scanf("%d",&T);
    for(int i=1;i<=T;i++)
    {
        int V,E;
        scanf("%d %d",&V,&E);   //V<=15,E<=1000,C<=1000
        Handle(V,E);
        printf("Case %d: %d\n",i,Max_flow(1,V,V,E));
    }
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章