HDU 5640 King's Cake(貪心)

King's Cake

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 827 Accepted Submission(s): 596


Problem Description
It is the king's birthday before the military parade . The ministers prepared a rectangle cake of size n×m(1n,m10000) . The king plans to cut the cake himself. But he has a strange habit of cutting cakes. Each time, he will cut the rectangle cake into two pieces, one of which should be a square cake.. Since he loves squares , he will cut the biggest square cake. He will continue to do that until all the pieces are square. Now can you tell him how many pieces he can get when he finishes.

Input
The first line contains a number T(T1000), the number of the testcases.

For each testcase, the first line and the only line contains two positive numbers n,m(1n,m10000).

Output
For each testcase, print a single number as the answer.

Sample Input
2 2 3 2 5

Sample Output
3 4 hint: For the first testcase you can divide the into one cake of $2\times2$ , 2 cakes of $1\times 1$

Source

/*
貪心:對於長n,寬m,排序
1: n,m   +1;
2: max(m,n-m),min(m,n-m) +1;
3:  .... 
直到n==n-m; 
   最後再加一個剩下的 
*/
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int n,m; 
int main(){
    int t,re;
    cin>>t;
    while(t--){
    	re=1;
    	cin>>n>>m;
    	if(n==m){
    		cout<<re<<endl;
    		continue;
    	}
    	else if(n<m){
    		int tmp=n;
    		n=m;
    		m=tmp;
    	}
    	while(n!=m){
    		re++;
    		n=n-m;
			if(n<m){
    		int tmp=n;
    		n=m;
    		m=tmp;
    	}		
    	}
    	cout<<re<<endl;
    }
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章