矩陣快速冪求斐波那契數列

矩陣快速冪求斐波那契數列

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.在這裏插入圖片描述

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input
The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output
For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint
As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.在這裏插入圖片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.在這裏插入圖片描述
完整代碼:

#include <iostream>
#include<cstring>
typedef long long ll;
using namespace std;

struct mat
{
    ll a[2][2];
};

mat mat_mul(mat x,mat y)
{
    mat res;
    memset(res.a,0,sizeof(res.a));
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<2;j++)
        {
            for(int k=0;k<2;k++)
            {
                res.a[i][j]=(res.a[i][j]+x.a[i][k]*y.a[k][j])%10000;
            }
        }
    }
    return res;
}

void mat_pow(int n)
{
    mat c,res;
    c.a[0][0]=c.a[0][1]=c.a[1][0]=1;
    c.a[1][1]=0;
    memset(res.a,0,sizeof(res.a));
    for(int i=0;i<2;i++)
    {
        res.a[i][i]=1;
    }
    while(n)
    {
        if(n&1)
        {
            res=mat_mul(res,c);
        }
        c=mat_mul(c,c);
        n=n>>1;
    }
    cout<<res.a[0][1]<<endl;
}

int main()
{
    int n;
    while(cin>>n)
    {
        if(n==-1)
        {
            break;
        }
        mat_pow(n);
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章