Recursive sequence(矩陣快速冪)

Recursive sequence

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
Sample Input

2
3 1 2
4 1 10

Sample Output

85
369

Hint

In the first case, the third number is 85 = 21十2十3^4.
In the second case, the third number is 93 = 2
1十1*10十3^4 and the fourth number is 369 = 2 * 10 十 93 十 4^4.

思路:
找到規律然後寫出板子,然後帶入算好的矩陣。規律和矩陣很難算。當然規律提示給了是:a[i+1]=2a[i-1]+a[i]+(i+1)^4, 然後表示(i+1)^4。這個用二項式展開這個就行了(其實就是算起來很難算很麻煩)。如圖:

在這裏插入圖片描述

完整代碼:

#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
const ll MOD=2147493647ULL;			//在常數後面增加一個U標識,因爲是long long型的所以加一個ULL(我因爲這個點WA了一次)
const int maxn=7;					//不加會報一個warning,但運行時樣例是對的
#define mod(x) ((x)%MOD)

struct mat
{
    ll m[maxn][maxn];
}unit;

mat operator *(mat a,mat b)
{
    mat ret;
    ll x;
    for(int i=0;i<maxn;i++)
    {
        for(int j=0;j<maxn;j++)
        {
            x=0;
            for(int k=0;k<maxn;k++)
            {
                x+=mod((ll)a.m[i][k]*b.m[k][j]);
            }
            ret.m[i][j]=mod(x);
        }
    }
    return ret;
}

void init_unit()
{
    for(int i=0;i<maxn;i++)
    {
        unit.m[i][i]=1;
    }
    return ;
}

mat pow_mat(mat a,ll n)
{
    mat ret=unit;
    while(n)
    {
        if(n&1)
        {
            ret=ret*a;
        }
        a=a*a;
        n>>=1;
    }
    return ret;
}

int main()
{
    int t;
    cin>>t;
    init_unit();
    ll A,B,n;
    while(t--)
    {
        cin>>n>>A>>B;
        if(n==1)
        {
            cout<<A<<endl;
        }
        else if(n==2)
        {
            cout<<B<<endl;
        }
        else
        {
            mat a,b;

            b.m[0][0]=1;b.m[0][1]=1;b.m[0][2]=0;b.m[0][3]=0;b.m[0][4]=0;b.m[0][5]=0;b.m[0][6]=0;
            b.m[1][0]=2;b.m[1][1]=0;b.m[1][2]=0;b.m[1][3]=0;b.m[1][4]=0;b.m[1][5]=0;b.m[1][6]=0;
            b.m[2][0]=1;b.m[2][1]=0;b.m[2][2]=1;b.m[2][3]=0;b.m[2][4]=0;b.m[2][5]=0;b.m[2][6]=0;
            b.m[3][0]=4;b.m[3][1]=0;b.m[3][2]=4;b.m[3][3]=1;b.m[3][4]=0;b.m[3][5]=0;b.m[3][6]=0;
            b.m[4][0]=6;b.m[4][1]=0;b.m[4][2]=6;b.m[4][3]=3;b.m[4][4]=1;b.m[4][5]=0;b.m[4][6]=0;
            b.m[5][0]=4;b.m[5][1]=0;b.m[5][2]=4;b.m[5][3]=3;b.m[5][4]=2;b.m[5][5]=1;b.m[5][6]=0;
            b.m[6][0]=1;b.m[6][1]=0;b.m[6][2]=1;b.m[6][3]=1;b.m[6][4]=1;b.m[6][5]=1;b.m[6][6]=1;

            a.m[0][0]=B;a.m[0][1]=A;a.m[0][2]=16;a.m[0][3]=8;a.m[0][4]=4;a.m[0][5]=2;a.m[0][6]=1;
            b = pow_mat(b,n-2);
            a=a*b;
            cout<<mod(a.m[0][0])<<endl;
        }
    }
    return 0;
}

小知識:(注意)C語言中常量值默認是一個32位的有符號整型數。由於2394967295無法用32位的有符號整型數表示,所以會有報警產生,即該問題通常出現在默認型存儲不夠的情況下。
在常數後面增加一個U標識,如果是long或longlong類型加ULULL,如4286545791U進行類型強制轉換,這樣就不會報警了。

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章