[POJ 3311]Hie with the Pie(状压DP+Floyd)

Description


The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input


Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

Output


For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input


3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output


8

Solution

好气哦,调了好长时间还重写了一遍
结果发现送完还要回到披萨店…我的阅读理解能力可能出现了障碍

从披萨店出发,要经过每个送餐点(可以重复经过),再回到披萨店,求总共需要的最少时间
Floyd处理出所有最短路
f数组第一维记录每个地点是否被经过的状态,第二维记录此时所在的地点
init中的处理使得state数组记录的状态相当于是按照去到的地方从少到多排序的

#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<cstdlib>
#define Min(a,b) (a<b?a:b)
#define inf 0x3f3f3f3f
using namespace std;
int n,dis[11][11],state[1100],tot,s[11][1100],num[11];
int f[1100][11];
int count(int x)
{
    int cnt=0;
    while(x)
    {
        if(x&1)cnt++;
        x>>=1;
    }
    return cnt;
}
void init()
{
    memset(num,0,sizeof(num));
    memset(f,0x3f,sizeof(f));
    tot=0;
    for(int i=0;i<(1<<n);i++)
    {
        int x=count(i);
        s[x][++num[x]]=i;
        if(x==1)f[i][num[1]]=dis[0][num[1]];
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=num[i];j++)
        {
            state[++tot]=s[i][j];
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        memset(dis,0x3f,sizeof(dis));
        for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
        scanf("%d",&dis[i][j]);
        for(int k=0;k<=n;k++)
        for(int i=0;i<=n;i++)
        for(int j=0;j<=n;j++)
        dis[i][j]=Min(dis[i][j],dis[i][k]+dis[k][j]);
        init();
        for(int i=1;i<=tot;i++)
        {
            for(int j=1;j<=n;j++)
            {
                if(!(state[i]&(1<<(j-1))))continue;
                int t=state[i]^(1<<(j-1));
                for(int k=1;k<=n;k++)
                {
                    if(!(t&(1<<(k-1))))continue;
                    f[state[i]][j]=Min(f[state[i]][j],f[t][k]+dis[k][j]);
                }
            }
        }
        int ans=inf;
        for(int i=1;i<=n;i++)
        ans=Min(ans,f[(1<<n)-1][i]+dis[i][0]);
        printf("%d\n",ans);

    }
    return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章