PAT Advanced 1086 Tree Traversals Again

1086 Tree Traversals Again

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

img
Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop 

Sample Output:

3 4 2 6 5 1

解題思路

通過stack模擬, push表示二叉樹的前序值,pop表示二叉樹的中序的值。 完成輸入後則得到中序和前序遍歷結果。通過中序和前序構建二叉樹(建立的過程類似於1020)之後,後序遍歷輸出即可。

解題代碼

#include <iostream>
#include <stack>
#include <cstdio>
using namespace std;
int n, lenp, leni, cnt, pre[30], in[30];
string op;
stack<int> st;
struct node{
    int data;
    node* lchild;
    node* rchild;
};
void post(node* root){
    if (root == NULL) return;
    post(root->lchild);
    post(root->rchild);
    printf("%d", root->data);
    cnt ++;
    if (cnt < n) printf(" ");
}
node* create(int preL, int preR, int iL, int iR){
    if (preL > preR) return NULL;
    node* root = new node;
    root->data = pre[preL];
    int k;
    for (k = iL ; k < iR; k++)
        if (in[k] == pre[preL]) break;
    int numberL = k - iL;
    root->lchild = create(preL + 1, preL + numberL, iL, k - 1);
    root->rchild = create(preL + numberL + 1, preR, k + 1, iR);
    return root;
}
int main(){
    scanf("%d", &n);
    for (int i = 0; i < 2 * n; i++){
        cin >> op;
        if (op == "Push"){
            int t;
            scanf("%d",&t);
            pre[lenp++] = t;
            st.push(t);
        } else{
            in[leni++] = st.top();
            st.pop();
        }
    }
    node* root = create(0, n - 1, 0, n - 1);
    post(root);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章