PAT Advanced 1102 Invert a Binary Tree

1102 Invert a Binary Tree

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.   

Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6    

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

解題思路

給定一顆二叉樹,將它左右孩子結點轉換後,重新構建一顆二叉樹, 輸出層序遍歷和前序遍歷的結果,如下圖解析輸入案例:

由上圖解, 解題步驟如下:

  1. 通過給定的輸入序列構建二叉樹(通過dfs)
  2. 構建完成層序遍歷使用bfs
  3. 前序遍歷每個結點 dfs

注意輸出格數:中間的空格以及,並且結尾沒有空格。

解題代碼

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
int cnt, n, h[20], tree[20][2], invt[20][2];
void dfs(int v){
    if (v == -1) return;
    dfs(tree[v][0]), dfs(tree[v][1]);
    swap(tree[v][0], tree[v][1]);
}
void print(int v){
    printf("%d", v);
    cnt ++;
    if (cnt < n) printf(" ");
}
void preorder(int v){
    if (v == -1) return;
    preorder(tree[v][0]);
    print(v);
    preorder(tree[v][1]);
}
void bfs(int root){
    queue<int> q;
    q.push(root);
    while (!q.empty()){
        int top = q.front();
        q.pop();
        print(top);
        if (tree[top][0] != -1) q.push(tree[top][0]);
        if (tree[top][1] != -1) q.push(tree[top][1]);
    }
}
int main(){
    scanf("%d", &n);
    for (int i = 0; i < n; i++){
        string sl, sr;
        cin >> sl >> sr;
        tree[i][0] = tree[i][1] = -1;
        if (sl != "-") tree[i][0] = stoi(sl), h[stoi(sl)] = 1;
        if (sr != "-") tree[i][1] = stoi(sr), h[stoi(sr)] = 1;
    }
    int root;
    for(int i = 0; i < n; i ++) if (!h[i]) root = i;
    dfs(root);
    bfs(root);
    puts(""), cnt = 0;
    preorder(root);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章