PAT Advanced 1099 Build A Binary Search Tree

1099 Build A Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42   

Sample Output:

58 25 82 11 38 67 45 73 42

解題思路

給定一顆二叉樹,並且給定對應n個結點的值, 是他們符合二叉搜索樹,構建完成二叉搜索樹之後,中序遍歷輸出對應結點的值。

本題需要根據輸入構建二叉樹,方法類似於1102, 但是本題需要保存結點的值可以使用結構體存儲,根據二叉搜索樹的性質:中序遍歷的時候,結點的數值是依次遞增的, 那麼只需要排序給定的數組,中序遍歷時,每個結點對應依次增加的的值即可。 完成賦值之後, bfs依次輸出每層結點的值。

解題代碼

#include <cstdio>
#include <algorithm>
#include <queue>
using namespace std;
const int N = 1010;
int n, cnt, a[N];
struct {
    int data, lchild, rchild;
}node[N];
void dfs(int v){
    if (v == -1) return;
    dfs(node[v].lchild);
    node[v].data = a[cnt++];
    dfs(node[v].rchild);
}
void print(int v){
    printf("%d", v);
    cnt ++;
    if (cnt < n) printf(" ");
}
void bfs(int root){
    cnt = 0;
    queue<int> q;
    q.push(root);
    while (!q.empty()){
        int head = q.front();
        q.pop();
        print(node[head].data);
        if (node[head].lchild != -1) q.push(node[head].lchild);
        if (node[head].rchild != -1) q.push(node[head].rchild);
    }
}
int main(){
    scanf("%d", &n);
    int l, r;
    for (int i = 0; i < n; i ++)
        scanf("%d %d", &node[i].lchild, &node[i].rchild);
    for (int i = 0; i < n; i++) scanf("%d", &a[i]);
    sort(a, a + n);
    dfs(0), bfs(0);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章