PAT Advanced 1094 The Largest Generation

1094 The Largest Generation

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]    

where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID's of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18   

Sample Output:

9 4    

解題思路

  • dfs

    dfs 遍歷整個二叉樹, 到每層處,對應的結點對應的層數值加1 ( num[level]++), 最後枚舉一遍找到最大值以及對應的層數 。

  • bfs

    bfs遍歷整個二叉樹, 每層節點結點的 層數等於 父節點 層數+ 1, num[v[head][i]] = num[head] + 1, 找到層數後, 對應節點的層數加一h[num[head]] ++

解題代碼

dfs:遞歸到每層, 對應層數的結點個數加1

#include <cstdio>
#include <vector>
using namespace std;
const int  N = 110;
int maxn, maxl, num[N];
vector<int> v[N];
void dfs(int cur, int level){
    num[level]++;
    for (int i = 0; i < v[cur].size(); i++){
        dfs(v[cur][i], level + 1);
    }
}
int main(){
    int n, m, p, k, c;
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; i++){
        scanf("%d %d", &p, &k);
        for (int j =0; j < k; j++){
            scanf("%d", &c);
            v[p].push_back(c);
        }
    }
    dfs(1, 1);
    for (int i = 0; i < N; i++){
        if (num[i] > maxn) maxn = num[i], maxl = i;
    }
    printf("%d %d", maxn, maxl);
    return 0;
}

bfs: 首先num表示每天節點的層數,通過hash 計數沒層結點的個數,兩次hash的使用。

#include <cstdio>
#include <vector>
#include <queue>
using namespace std;
const int  N = 100;
int maxn, maxl, num[N], h[N];
vector<int> v[N];
void bfs(){
    queue<int> q;
    num[1] = 1;
    q.push(1);
    while (!q.empty()){
        int head = q.front();
        q.pop();
        int n = v[head].size();
        for (int i = 0; i < n; i++)
            q.push(v[head][i]), num[v[head][i]] = num[head] + 1;
        h[num[head]] ++;
    }
}
int main(){
    int n, m, p, k, c;
    scanf("%d %d", &n, &m);
    for (int i = 0; i < m; i++){
        scanf("%d %d", &p, &k);
        for (int j =0; j < k; j++){
            scanf("%d", &c);
            v[p].push_back(c);
        }
    }
    bfs();
    for (int i = 0; i < N; i++)
        if (maxn < h[i]) maxn = h[i], maxl = i;
    printf("%d %d", maxn, maxl);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章