【HDU 3038】How Many Answers Are Wrong 帶權並查集

Problem Description
TT and FF are … friends. Uh… very very good friends -________-b

FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

BoringBoringa very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input
Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

You can assume that any sum of subsequence is fit in 32-bit integer.

Output
A single line with a integer denotes how many answers are wrong.

Sample Input
10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output
1

題意:給出n個區間內和,問有多少個當前區間和與前面矛盾

思路:

帶權並查集的模板題。當前區間矛盾的唯一條件就是通過之前已有區間得到的值不同。而且不能說【1,100】是10而【1,10】是100就矛盾,因爲可能有負值產生。
每次不同集合更新的方程如下圖,之後就是套模板了
在這裏插入圖片描述

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <queue>
#include <algorithm>
#define maxn 200555
using namespace std;
int father[maxn];
int sum[maxn];
int n,m;

int get(int x)
{
    if(father[x]!=x)
    {
        int i = father[x];
        father[x] = get(father[x]);
        sum[x] += sum[i];
    }
    return father[x];
}

void init()
{
    for(int i=0;i<=n;i++)
    father[i] = i, sum[i] =  0;
}

int main()
{
  //  ios::sync_with_stdio(false);
    while(~scanf("%d%d",&n,&m))
    {
        init();
        int ans = 0;
        for(int i=1;i<=m;i++)
        {
            int l,r,cost;
            cin>>l>>r>>cost;
            l--;
            int fl = get(l);
            int fr = get(r);
            if(fl==fr)
            {
                if(sum[l]-sum[r]!=cost)
                ans++;
            }
            else
            {
                 father[fl] = fr;
                 sum[fl] = sum[r] - sum[l] + cost;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章