PAT甲級1079 Total Sales of Supply Chain (25分) 層序遍歷

1079 Total Sales of Supply Chain (25分)
A supply chain is a network of retailers(零售商), distributors(經銷商), and suppliers(供應商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the total sales from all the retailers.

Input Specification:
Each input file contains one test case. For each case, the first line contains three positive numbers: N (≤10
​5
​​ ), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N−1, and the root supplier’s ID is 0); P, the unit price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

K
​i
​​ ID[1] ID[2] … ID[K
​i
​​ ]

where in the i-th line, K
​i
​​ is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. K
​j
​​ being 0 means that the j-th member is a retailer, then instead the total amount of the product will be given after K
​j
​​ . All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the total sales we can expect from all the retailers, accurate up to 1 decimal place. It is guaranteed that the number will not exceed 10
​10
​​ .

Sample Input:
10 1.80 1.00
3 2 3 5
1 9
1 4
1 7
0 7
2 6 1
1 8
0 9
0 4
0 3
Sample Output:
42.4

還是老套路,就是多了個葉子節點需要單獨處理,我還是習慣使用隊列來進行層序遍歷,中間每一次遞增價格

#include <iostream>
#include <algorithm>
using namespace std;
#include <vector>
#include <unordered_map>
#include <queue>





int main()
{
    int N;//0到N-1  根節點是0
    double rootPrice,rate;
    cin>>N>>rootPrice>>rate;
    vector<vector<int>> vec(N);
    for(int i=0; i<N; i++)
    {
        int num;
        cin>>num;
        if(num==0)
        {
            vec[i].push_back(-1);//零售商
            int sales;
            cin>>sales;
            vec[i].push_back(sales);
        }
        else
        {
            vec[i].push_back(1);
            for(int q=0; q<num; q++)
            {
                //供應商都是i
                int get;
                cin>>get;
                vec[i].push_back(get);
            }
        }
    }
    //感覺題意沒有說一個零售多個供應商,先按照每個零售的供應商唯一來
    double price[N]= {0};

    //還是類似層序遍歷試試吧
    queue<int> que;
    que.push(0);
    while(!que.empty())
    {
        queue<int> get;
        while(!que.empty())
        {
            int id=que.front();
            que.pop();

            //id下游的廠家的價格記錄 並且進入對了
            price[id]=rootPrice;
            if(vec[id][0]!=-1)
            {
                for(int i=1; i<vec[id].size(); i++)
                {
                    get.push(vec[id][i]);
                }
            }

        }
        rootPrice=rootPrice+rootPrice*rate/100;
        que=get;
    }
    double sum=0;
    for(int i=0;i<N;i++){
        if(vec[i][0]==-1){
            //printf("%f\n",price[i]*vec[i][1]);
            sum+=price[i]*vec[i][1];
        }
    }

    printf("%.1f",sum);
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章