PAT甲級1094 The Largest Generation (25分) 層序遍歷 vector嵌套來保存邊

1094 The Largest Generation (25分)
A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:
Each input file contains one test case. Each case starts with two positive integers N (<100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (<N) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a family member, K (>0) is the number of his/her children, followed by a sequence of two-digit ID’s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:
23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18
Sample Output:
9 4

常規題吧,PAT很多題都包括層序遍歷了
我還是習慣用vector<vector> vec(N)來保存邊,然後使用隊列遍歷每一層
代碼:

#include <iostream>
#include <algorithm>
using namespace std;
#include <unordered_map>
#include <queue>
#include <vector>
int main()
{
    //int sn[100][100]={0};
    vector<vector<int>> sn(100);
    int N,M;
    cin>>N>>M;
    int sign[N]={0};
    for(int i=0;i<M;i++){
        int id;
        cin>>id;
        int num;
        cin>>num;
        for(int m=0;m<num;m++){
            int get;
            cin>>get;
            sn[id].push_back(get);
            sign[get]=-1;
        }
    }

    int root;
    for(int i=1;i<=N;i++){
        if(sign[i]==0){
            root=i;
            break;
        }
    }
     int level=1;
     int maxx=1;
     int maxLevel=1;
     queue<int> que;
     que.push(root);
     while(!que.empty()){
        queue<int> get;
        while(!que.empty()){
            int getNum=que.front();

            for(int i=0;i<sn[getNum].size();i++){
                get.push(sn[getNum][i]);

            }

            que.pop();
        }
        level++;
        if(get.size()>maxx){
            maxx=get.size();
            maxLevel=level;
        }

        que=get;
     }
     cout<<maxx<<' '<<maxLevel;
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章