【BFS 樹的層序遍歷】1004 Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:

For each test case, you are supposed to count those family members who have no child for every seniority levelstarting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:

2 1
01 1 02

Sample Output:

0 1
#include<stdio.h>
#include<vector>
#include<queue>
using namespace std;
vector<int> children[100];
int level[100];
int cnt[100];
int main(){
    int n, m;
    scanf("%d%d", &n, &m);
    if(!n) return 0;
    for(int i = 0; i < m; i++){
        int id, k;
        scanf("%d%d", &id, &k);
        for(int j = 0; j < k; j++){
            int d;
            scanf("%d", &d);
            children[id].push_back(d);
        }
    }
    queue<int> q;
    q.push(1);
    while(!q.empty()){
        int id = q.front();
        q.pop();
        if(children[id].size() == 0){
            cnt[level[id]]++;
        }
        else{
            for(int i = 0; i < children[id].size(); i++){
                q.push(children[id][i]);
                level[children[id][i]] = level[id]+1;
            }
        }
    }
    int maxL = 0;
    for(int i = 0; i < 100; i++)
        maxL = max(maxL, level[i]);
    for(int i = 0; i <= maxL; i++){
        if(i != 0) printf(" ");
        printf("%d", cnt[i]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章