POJ2253 Frogger


Frogger
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34865   Accepted: 11192

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

給定湖中兩隻青蛙所在的石頭,以及其他石頭的座標,試計算兩隻青蛙之間的青蛙距離。
青蛙距離:兩塊石頭之間所有路徑中的最大跳躍距離的最小值

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
多組數據
每組第一行爲整數n,表示石頭數目。接下來n行每行兩個整數xi和yi,表示第i塊石頭座標。
輸入文件最後一行爲0

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Source




因爲已經限定了兩隻青蛙在石頭1和2上,所以是單源最短路徑問題

跑了遍floyd就過了


求青蛙距離:map[i][j]=min(map[i][j],max(map[i][k],map[k][j])



#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int mxn=2000;
int x[mxn],y[mxn];//石頭座標 
double mp[210][210];//圖 
int n;
double dis(int x1,int x2,int y1,int y2){//求兩點間距離 
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void cdis(){//將兩點間距離存入鄰接矩陣 
	memset(mp,0,sizeof(0));
	int i,j;
	for(i=1;i<=n;i++)
	  for(j=1;j<=n;j++){
	  	mp[i][j]=dis(x[i],x[j],y[i],y[j]);
	  }
	return;
}
int main(){
	int T=0;
	while(scanf("%d",&n) && n){
		printf("Scenario #%d\n",++T);
		int i,j;
		for(i=1;i<=n;i++){
			scanf("%d%d",&x[i],&y[i]);
		}
		cdis();
		for(int k=1;k<=n;k++)
			for(i=1;i<=n;i++)
		  		for(j=1;j<=n;j++){
					mp[i][j]=min(mp[i][j],max(mp[i][k],mp[k][j]));
//					printf("%d  %d  %d\n",k,i,j);
//					printf("%.3f  %.3f  %.3f\n",mp[i][j],mp[i][k],mp[k][j]);
		  	}
		printf("Frog Distance = %.3f\n\n",mp[1][2]);//注意空行 
	}
	return 0;
}








發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章