ACM 1002題 A + B Problem II

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 406159    Accepted Submission(s): 78700



Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
21 2112233445566778899 998877665544332211
 
Sample Output
Case 1:1 + 2 = 3Case 2:112233445566778899 + 998877665544332211 = 1111111111111111110
 
Author
Ignatius.L
 

 

import java.math.*;
import java.util.*;

public class Main extends Object {

	private static final Scanner cache = new Scanner(System.in);

	public static void main(String[] args) {

		String a = new String();
		String b = new String();
		int j = 0;

		for (int i = cache.nextInt(); i > 0; i--) {
			j++;
			a = cache.next();
			b = cache.next();

			BigInteger bA = new BigInteger(a);
			BigInteger bB = new BigInteger(b);

			BigInteger sum = bA.add(bB);

			System.out.println("Case " + j + ":");
			System.out.println(bA.toString() + " + " + bB.toString() + " = " + sum.toString());
			if (!(i == 1)) {
				System.out.println();
			}
		}

	}

}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章