poj1222(高斯消元,開關問題)

地址:http://poj.org/problem?id=1222

EXTENDED LIGHTS OUT
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6305   Accepted: 4140

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

題意:輸入目標狀態,問怎樣操作纔可以使全關的燈達到目標狀態。

思路:開關問題的典型,直接高斯消元就可以,可以拿這題作爲高斯消元的入門題。

代碼:

#include<iostream>
#include<queue>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define LL __int64
#define col 30
int num[40][40],ans[40];
void getans(){
    for(int i=0,m=0;i<col,m<col;m++){
        int k=i;
        for(int j=i+1;j<col;j++){  //將最大的前移
            if(abs(num[j][m])>abs(num[k][m]))
                k=j;
        }
        if(k!=i){
            for(int j=m;j<=col;j++)
                swap(num[i][j],num[k][j]);
        }
        if(!num[i][m]) continue;  //有可能存在中間一列全都爲零
        for(int j=i+1;j<col;j++){
            if(!num[j][m]) continue;
            for(k=m;k<=col;k++)
                num[j][k]^=num[i][k];  //這裏想明白了,因爲我們操作恆置爲1,所以操作狀態爲0的開關會使其變爲1,反之操作狀態爲1的開關會使其變爲0
        }
        i++;
    }
    for(int i=col-1;i>=0;i--){
        ans[i]=num[i][col];
        for(int j=i+1;j<col;j++)
            ans[i]^=(num[i][j]&ans[j]);  //需要注意,這種求答案只適用於開關問題一類的題目
    }
}
int main(){
    int t,cas=1;
    scanf("%d",&t);
    while(t--){
        memset(num,0,sizeof(num));
        for(int i=0;i<5;i++)
            for(int j=0;j<6;j++){
                int s=i*6+j;
                num[s][s]=1;
                if(i>0) num[s-6][s]=1;
                if(i<4) num[s+6][s]=1;
                if(j>0) num[s-1][s]=1;
                if(j<5) num[s+1][s]=1;
            }
        for(int i=0;i<col;i++)
            scanf("%d",&num[i][col]);
        getans();
        printf("PUZZLE #%d",cas++);
        for(int i=0;i<col;i++)
            if(i%6==0)printf("\n%d",ans[i]);
            else printf(" %d",ans[i]);
        puts("");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章