hdu-1102 Constructing Roads(prim最小生成樹)

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12591    Accepted Submission(s): 4792


Problem Description
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.
 

Input
The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.
 

Output
You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 
 

Sample Input
3 0 990 692 990 0 179 692 179 0 1 1 2
 

Sample Output
179
 
解題思路:
最小生成樹,prim算法。把已經相鄰的點之間的權值設爲0
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
#define maxn 120
#define inf 0x3fffffff
int n,q;
int _map[maxn][maxn];
int lowc[maxn];

int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
        {
            lowc[i]=inf;
            for(int j=0;j<n;j++)
            {
                scanf("%d",&_map[i][j]);
                _map[j][i]=_map[i][j];
            }
        }
        scanf("%d",&q);
        while(q--)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            _map[a-1][b-1]=_map[b-1][a-1]=0;
        }
        int next;
        int start=0;
        int ans=0;
        while(1)//核心代碼
        {
            lowc[start]=-1;
            next=-1;
            int dis=inf;
            for(int i=0;i<n;i++)
            {
                lowc[i]=min(lowc[i],_map[i][start]);
                if(lowc[i]!=-1&&lowc[i]<dis)
                {
                    dis=lowc[i];
                    next=i;
                }
            }
            if(next==-1)
                break;
            start=next;
            ans+=dis;
        }
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章