poj 3041Asteroids+3692Kindergarten(二分圖匹配+公式補充)

Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13780   Accepted: 7493

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source

問題描述
有一個N*N的網格,放有k個星星。

Bessie有一個強大的武器,每次可以清掃任意一行或者任意一列上所有的星星。當時武器非常昂貴,給出K個星星的位置,用最少的武器清掃乾淨所有的星星。

解題思路:
最小頂點覆蓋:
用最少的頂點覆蓋所有的邊
二分圖最小頂點覆蓋 = 最大匹配

採用匈牙利算法:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
bool _map[520][520];
int vis[520];
int link[520];//記錄n2中的點在n1中所匹配的點的編號,即匹配集合M
int n,k;
int n1,n2;//爲二分圖的兩個頂點集
bool Find(int x)
{
    for(int i=0;i<n2;i++)
    {
        if(_map[x][i]&&!vis[i])//x和i有邊,且節點i未被搜索
        {
            vis[i]=1;
            if(link[i]==-1||Find(link[i]))//如果i不屬於前一個匹配M,或者i匹配的節點可以找到一條增廣路
            {
                link[i]=x;//更新
                return true;
            }
        }
    }
    return false;
}
int mach()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0;i<n1;i++)
    {
        memset(vis,0,sizeof(vis));
        if(Find(i))//如果從第i個點找到了增廣路
            ans++;
    }
    return ans;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        memset(_map,0,sizeof(_map));
        int r,c;
        for(int i=1;i<=k;i++)
        {
            scanf("%d%d",&r,&c);
            _map[r-1][c-1]=true;
        }
        n1=n2=n;
        printf("%d\n",mach());
    }
    return 0;
}

Kindergarten
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4798   Accepted: 2334

Description

In a kindergarten, there are a lot of kids. All girls of the kids know each other and all boys also know each other. In addition to that, some girls and boys know each other. Now the teachers want to pick some kids to play a game, which need that all players know each other. You are to help to find maximum number of kids the teacher can pick.

Input

The input consists of multiple test cases. Each test case starts with a line containing three integers
GB (1 ≤ GB ≤ 200) and M (0 ≤ M ≤ G × B), which is the number of girls, the number of boys and
the number of pairs of girl and boy who know each other, respectively.
Each of the following M lines contains two integers X and Y (1 ≤ X≤ G,1 ≤ Y ≤ B), which indicates that girl X and boy Y know each other.
The girls are numbered from 1 to G and the boys are numbered from 1 to B.

The last test case is followed by a line containing three zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) followed by a integer which is the maximum number of kids the teacher can pick.

Sample Input

2 3 3
1 1
1 2
2 3
2 3 5
1 1
1 2
2 1
2 2
2 3
0 0 0

Sample Output

Case 1: 3
Case 2: 4

Source


問題描述:

在幼兒園中,有很多小孩,男孩之間互相認識,女孩之間也互相認識。而且,知道一些女孩男孩之間相互認識。現在老師要組織一個遊戲,需要參加遊戲的人之間相互認識。求老師可挑選參加遊戲的最大人數。

題目分析:

這個題目相當於求最大團。下面我就來補充幾個概念,和幾個公式

1、獨立集:任何兩點都不相鄰。

2、團:任何兩點都相鄰。

3、最大獨立集 = 頂點數 - 最大匹配數

4、最小頂點覆蓋 = 最大匹配數

5、最小路徑覆蓋 = 最大獨立集

6、最大團 = 補圖的最大獨立集

下面就直接運用第六個公式,先構建一個補圖,之後求最大匹配數。結果用頂點數一減就完事了。

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<vector>
#include<algorithm>
#include<iostream>
using namespace std;
#ifdef __int64
typedef __int64 LL;
#else
typedef long long LL;
#endif
bool _map[300][300];
int vis[300];
int link[300];
int n1,n2;
int G,B,M;
bool Find(int x)
{
    for(int i=0;i<n2;i++)
    {
        if(_map[x][i]&&!vis[i])
        {
            vis[i]=1;
            if(link[i]==-1||Find(link[i]))
            {
                link[i]=x;
                return true;
            }
        }
    }
    return false;
}
int mach()
{
    int ans=0;
    memset(link,-1,sizeof(link));
    for(int i=0;i<n1;i++)
    {
        memset(vis,0,sizeof(vis));
        if(Find(i))
            ans++;
    }
    return ans;
}
int main()
{
    int kase=1;
    while(scanf("%d%d%d",&G,&B,&M)&&G&&B&&M)
    {
        for(int i=0;i<G;i++)//構建原二分圖的補圖
            for(int j=0;j<B;j++)
                _map[i][j]=true;
        int g,b;
        for(int i=0;i<M;i++)
        {
            scanf("%d%d",&g,&b);
            _map[g-1][b-1]=false;
        }
        n1=G; n2=B;
        printf("Case %d: %d\n",kase++,G+B-mach());
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章