POJ2381——TOYS(暴力,叉積)

TOYS
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 10850   Accepted: 5208

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source


題意:給你一個矩形,有n條線段(線段兩個端點分別位於矩形的上下邊界)將這個矩形劃分成n+1塊的區域,然後有m個點分佈在矩形中,問每個區域內的點的個數。

思路:利用向量的叉積,cross(v,w)>0 則 w位於v左側  ; cross(v,w)<0 則 w位於v右側 

#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cmath>
#include <cstring>
#include <iostream>
#define INF 0x7fffffff
using namespace std;

typedef long long LL;
const int N = 5000 + 10;

const double esp = 1e-10;
int dcmp(double x) {if(fabs(x) < esp) return 0; else return x<0?-1:1;}

struct Point
{
    double x,y;
    Point(double x=0,double y=0):x(x),y(y){ }
};

typedef Point Vector;

Vector operator + (Vector A, Vector B) {return Vector(A.x+B.x, A.y+B.y);}
Vector operator - (Vector A, Vector B) {return Vector(A.x-B.x, A.y-B.y);}
Vector operator * (Vector A, double p) {return Vector(A.x*p, A.y*p);}
Vector operator / (Vector A, double p) {return Vector(A.x/p, A.y/p);}
bool operator < (const Point& a, const Point& b){ return a.x<b.x || (a.x==b.x && a.y<b.y);}
bool operator == (const Point& a, const Point& b){return dcmp(a.x-b.x)==0 && dcmp(a.y-b.y)==0;}

double Dot(Vector A, Vector B){ return A.x*B.x+A.y*B.y; }
double Length(Vector A){return sqrt(Dot(A, A));}
double Angle(Vector A, Vector B) {return acos( Dot(A, B)/Length(A)/Length(B) );}

double Cross(Vector A, Vector B) { return A.x*B.y - A.y*B.x ;}
double Area2(Point A, Point B, Point C){return Cross(B-A, C-A); }

Point B[N][2];
int cnt[N];
int n,m;

int check(Point A)
{
    for(int i=0;i<n;i++)
    {
        Vector W = A - B[i][1];
        Vector V = B[i][0] - B[i][1];

        if(Cross(V, W)>0) return i;
    }
    return n;
}
int main()
{
    int x1,x2,y1,y2;
    while(scanf("%d",&n)!=EOF&&n)
    {
        scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
        int U, L, x, y;
        memset(cnt,0,sizeof(cnt));

        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&U,&L);
            Point p1(U,y1), p2(L,y2);

            B[i][0] = p1;
            B[i][1] = p2;
        }
        for(int i=0;i<m;i++)
        {
            Point A;
            scanf("%lf%lf",&A.x, &A.y);
            cnt[check(A)]++;
        }
        for(int i=0;i<=n;i++)
        {
            printf("%d: %d\n",i,cnt[i]);
        }
        printf("\n");
    }
    return 0;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章