2014071901

查找最大元素

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 38 Accepted Submission(s) : 5

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

對於輸入的每個字符串,查找其中的最大字母,在該字母后面插入字符串“(max)”。

Input

輸入數據包括多個測試實例,每個實例由一行長度不超過100的字符串組成,字符串僅由大小寫字母構成。

Output

對於每個測試實例輸出一行字符串,輸出的結果是插入字符串“(max)”後的結果,如果存在多個最大的字母,就在每一個最大字母后面都插入"(max)"。

Sample Input

abcdefgfedcba
xxxxx

Sample Output

abcdefg(max)fedcba
x(max)x(max)x(max)x(max)x(max)

Author

lcy

Source

C語言程序設計練習(四) 

////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>
//還有一個問題,總是當成java提交了
using namespace std;
char x[10000];
int main()
{
    int max,i,j,k,len;
    while(scanf("%s",x)!=EOF)
    {
        max=0;//記錄最大的位置
        len=strlen(x);
        //找到最大
        for(i=0;i<len;i++)
        {
            if(x[i]>x[max])
                max=i;
        }


        for(i=0;i<len;i++)
        {
            printf("%c",x[i]);//不論什麼樣都先輸出
            if(x[i]==x[max])//每一次都輸出,開始只是第一次輸出了
            printf("(max)");//不用存儲
        }


        printf("\n");
        memset(x,'\0',sizeof(x));
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章