hdu6098Inversion

Inversion

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 602    Accepted Submission(s): 401


Problem Description
Give an array A, the index starts from 1.
Now we want to know Bi=maxijAj , i2.
 

Input
The first line of the input gives the number of test cases T; T test cases follow.
Each case begins with one line with one integer n : the size of array A.
Next one line contains n integers, separated by space, ith number is Ai.

Limits
T20
2n100000
1Ai1000000000
n700000
 

Output
For each test case output one line contains n-1 integers, separated by space, ith number is Bi+1.
 

Sample Input
2 4 1 2 3 4 4 1 4 2 3
 

Sample Output
3 4 3 2 4 4
主要是看懂公式: maxijAj
 
i不能整除j
由此有兩種方式解決,可以用結構體排序,將權值大的排在前面,再對下標進行篩選
還可以直接枚舉,但有一個優化,先對a選出最大的數和座標,然後判斷maxa是否滿足,不滿足再從1~n中枚舉篩選
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
#define N 100010
#define LL long long
LL a[N];
LL b[N];
int main()
{
    int t;
    LL n;

    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%lld",&n);
        LL maxa=0;
        LL maxa_i=0;
        for(int i=1; i<=n; i++)
        {
            scanf("%lld",&a[i]);
            if(a[i]>maxa)
            {
                maxa=a[i];
                maxa_i=i;
            }
        }
        //int maxx;
        for(int i=2;i<=n+1;i++)
        {
            if(maxa_i%i==0)
            {
                LL mm=0;
                for(int j=1;j<=n;j++)
                {
                    if(j%i==0)continue;
                    if(a[j]>mm)
                    {
                        mm=a[j];
                    }
                }
                b[i]=mm;
            }
            else
            b[i]=maxa;
        }
        for(int i=2;i<n;i++)
        {
            cout<<b[i]<<' ';
        }
        cout<<b[n]<<endl;
    }
    return 0;
}


 

maxijAj , i2.
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章