hdu6095Rikka with Competition(水)

Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 418 Accepted Submission(s): 345

Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestling match will be held tomorrow. n players will take part in it. The ith player’s strength point is ai.

If there is a match between the ith player plays and the jth player, the result will be related to |ai−aj|. If |ai−aj|>K, the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n−1 matches, the last player will be the winner.

Now, Yuta shows the numbers n,K and the array a and he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?

Input
The first line contains a number t(1≤t≤100), the number of the testcases. And there are no more than 2 testcases with n>1000.

For each testcase, the first line contains two numbers n,K(1≤n≤105,0≤K<109).

The second line contains n numbers ai(1≤ai≤109).

Output
For each testcase, print a single line with a single number – the answer.

Sample Input
2
5 3
1 5 9 6 3
5 2
1 5 9 6 3

Sample Output
5
1

題意:從給定的人裏面每次選兩個比賽,輸的淘汰,問最多能有幾個win

倒序一一比較

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
int vist[100010];
int a[100010];
int check(int x,int y)
{
    if(a[x]>a[y])
        return x;
    else
        return y;
}
int main()
{
    int n,k;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        memset(vist,0,sizeof(vist));
        for(int i=0; i<n; i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a,a+n);
        int ans=a[n-1];
        int res=0;
        for(int i=n-2; i>=0; i--)
        {
            if(abs(ans-a[i])>k)
            {
                res++;
                break;
            }
            else
            {
                ans=a[i];
                res++;
            }
            if(i==0)
            res++;
        }
        cout<<res<<endl;
    }

    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章