Cow Exhibition(DP)

Description
“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output
  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8
Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

一堆牛,有智商和情商,選出一些牛,在智商和和情商和都不爲負數的前提下,求情商和智商和的最大。

昨天寫了那麼多題,頭昏腦漲,今早看了一下發現就是揹包,隨便以智商或是情商爲揹包,求在這個智商下,情商的最大值,由於是要把容量完全裝滿,所以初始化除了dp[0] = 0;其他全爲-inf。
然後wa了。
發現負數無法處理,可以看到數據範圍是-1e5~1e5,可以加一個偏移量1e5即可。

還有一個優化就是每個情商是-1000到1000的,所以每次擴大搜索範圍1000就行了,減少了很多不必要的更新。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
const int lea = 1e5;
int dp[200005];
struct Node
{
    int x,y;
}node[105];
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int n,len = 200000;
    scanf("%d",&n);
    for(int i = 1;i <= n;i++)
    {
        scanf("%d%d",&node[i].x,&node[i].y);
    }
    for(int i = 0;i <= len;i++)dp[i] = -inf;
    dp[lea] = 0;
    for(int i = 1;i <= n;i++)
    {
        //if(node[i].x + node[i].y < 0)continue;
        if(node[i].x > 0)
            for(int j = lea + (i - 1)*1000 + node[i].x;j >= lea - (i - 1)*1000 + node[i].x;j--)
                dp[j] = max(dp[j],dp[j - node[i].x] + node[i].y);
        else
        {
            for(int j = lea - (i - 1)*1000 + node[i].x;j <= lea + (i - 1)*1000 + node[i].x;j++)
                dp[j] = max(dp[j],dp[j - node[i].x] + node[i].y);
        }
    }
    int ans = 0;
    for(int i = lea;i <= len;i++)
        if(dp[i] >= 0)
        ans = max(ans,i - lea + dp[i]);
    if(ans >= 0)
        printf("%d\n",ans);
    else
        printf("0\n");
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章