Apple Catching(DP)

Description
It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.
Input
* Line 1: Two space separated integers: T and W

  • Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.
    Output
  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.
    Sample Input
    7 2
    2
    1
    1
    2
    2
    1
    1
    Sample Output
    6
    Hint
    INPUT DETAILS:

Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.

OUTPUT DETAILS:

Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

有兩棵蘋果樹,掉下n個蘋果,每個蘋果依次從第1或2棵樹上掉下,牛最多移動w次,問最多拿到多少蘋果。

dp[i][j][2]表示i個蘋果掉落,j次轉移,在哪個蘋果樹下。
然後根據這個xjb轉移就行了。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
#include<stack>
#include<utility>
#include<sstream>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int dp[1005][40][2];
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\ΡΡ\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\ΡΡ\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    memset(dp,0,sizeof(dp));
    int t,w,x;
    scanf("%d%d",&t,&w);
    scanf("%d",&x);
    if(x == 1)
    {
        dp[1][0][0] = 1;
    }
    else
    {
        dp[1][0][0] = 0;
        dp[1][1][1] = 1;
    }
    for(int i = 2;i <= t;i++)
    {
        scanf("%d",&x);
        if(x == 1)
        {
            dp[i][0][0] = dp[i - 1][0][0] + 1;
            for(int j = 1;j <= min(i,w);j++)
            {
                dp[i][j][0] = max(dp[i - 1][j][0],dp[i - 1][j - 1][1]) + 1;
                dp[i][j][1] = max(dp[i - 1][j][1],dp[i - 1][j - 1][0]);
            }
        }
        else
        {
            for(int j = 1;j <= min(i,w);j++)
            {
                dp[i][j][0] = max(dp[i - 1][j][0],dp[i - 1][j - 1][1]);
                dp[i][j][1] = max(dp[i - 1][j][1],dp[i - 1][j - 1][0]) + 1;
            }
        }
    }
    int ans = max(dp[t][min(t,w)][0],dp[t][min(t,w)][1]);
    printf("%d\n",ans);
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章