POJ 3628 Bookshelf 2 (01揹包)

Bookshelf 2
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7496   Accepted: 3451

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ BS, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source

USACO 2007 December Bronze

題意:就是給出n和b,然後給出n個數,用這n個數中的某些,求出一個和,這個和是>=b的最小值,輸出最小值與b的差。

分析:這道題很簡單,是很明顯的01揹包問題,這裏的n個物品,每個物品的重量爲c[i],價值爲w[i]並且c[i]==w[i],,容量爲所有c[i]的和sum。只要在f[]中從頭開始找,找到一個最小>=b的就是題目要的解

一開始看錯題了,以爲是最接近b的值,WA無數次。
代碼:46MS
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;
#define M 1000005
#define N 10005
int map[N],dp[M];
int main()
{
    int i,j,n,v,sum;
    while(cin>>n>>v)
    {
      memset(dp,0,sizeof(dp));
      memset(map,0,sizeof(map));
      sum=0;
      for(i=1;i<=n;i++) {cin>>map[i];sum+=map[i];}
      for(i=1;i<=n;i++)
      for(j=sum;j>=map[i];j--)
      dp[j]=max(dp[j],dp[j-map[i]]+map[i]);
      for(i=1;i<=sum;i++)
      {
          if(dp[i]>=v)    //明顯,第一個比v大的一定滿足條件。
          {cout<<dp[i]-v<<endl;break;}
      }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章