HDU 1062 Text Reverse(棧的應用)—— C++

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

題意:翻轉字符串。例如輸入 “olleh !dlrow” ,輸出 “hello world!” 。

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input

3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output

hello world!
I’m from hdu.
I like acm.

代碼

#include <stack>
#include<iostream>
#include<string>
using namespace std;
int main() {
	int n;
	cin >> n;getchar();                  // 獲取 ‘\n’ ,避免其影響 getline()
	while (n--) {
		stack<char>c;                    // 棧的聲明
		string a;getline(cin, a);
		for (int i = 0; i < a.length(); i++) {
			if (a[i] != ' ') {
				c.push(a[i]);            //入棧
				if (i == a.length() - 1) {
					while (!c.empty()) {
						cout << c.top(); //輸出棧頂
						c.pop();        //清除棧頂
					}
				}
			}
			else {
				while (!c.empty()) {
					cout << c.top();
					c.pop();
				}
				cout << " ";
			}
		}
		cout << endl;
	}	
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章