4388 Stone Game II

#博弈論的問題基本上是同一種想法——找規律。往往是通過很特殊的情況往一般情況衍生,或者說分析出特殊情況的必勝狀態,一般情況往特殊情況靠攏。

#還有特別使用到的是二進制,許多問題的分類都藉助了二進制的優勢,不論怎樣表述的物品,比如格子、石頭堆,二進制可以自動分類形成2^0,2^1等堆,在這種情況下進行異或操作有着天然的優勢。

#對於這道題而言,發現規律:所有石頭數量的奇偶性與石頭堆數的奇偶性異或,如果爲1則先手勝。

#問題

Stone Game II

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 457    Accepted Submission(s): 261


Problem Description
  Stone Game II comes. It needs two players to play this game. There are some piles of stones on the desk at the beginning. Two players move the stones in turn. At each step of the game the player should do the following operations.
  First, choose a pile of stones. (We assume that the number of stones in this pile is n)
  Second, take some stones from this pile. Assume the number of stones left in this pile is k. The player must ensure that 0 < k < n and (k XOR n) < n, otherwise he loses.
  At last, add a new pile of size (k XOR n). Now the player can add a pile of size ((2*k) XOR n) instead of (k XOR n) (However, there is only one opportunity for each player in each game).
The first player who can't do these operations loses. Suppose two players will do their best in the game, you are asked to write a program to determine who will win the game.
 

Input
  The first line contains the number T of test cases (T<=150). The first line of each test cases contains an integer number n (n<=50), denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game. 
You can assume that all the number of stones in each pile will not exceed 100,000.
 

Output
  For each test case, print the case number and the answer. if the first player will win the game print "Yes"(quotes for clarity) in a single line, otherwise print "No"(quotes for clarity).
 

Sample Input
3 2 1 2 3 1 2 3 4 1 2 3 3
 

Sample Output
Case 1: No Case 2: Yes Case 3: No

#AC碼

#include<iostream>
using namespace std;
int main()
{
    int t,i,j,n,te;
    cin>>t;
    for(i=1;i<=t;i++)
    {
        cin>>n;
        int cnt=0;
        for(j=1;j<=n;j++)
        {
            cin>>te;
            while(te)
            {
                if(te&1)
                    cnt++;
                te=te>>1;
            }
        }
        if((n%2)^(cnt%2))
            cout<<"Case "<<i<<": "<<"Yes"<<endl;
        else
             cout<<"Case "<<i<<": "<<"No"<<endl;
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章