【poj 3401 二分圖最大匹配】

點擊打開鏈接


Asteroids
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 23503   Accepted: 12749

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).



#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int f[505];
bool fr[505][505];
bool vis[505];
int k,n,m;
bool find(int x)
{
	for(int i = 1;i <= n;i++)
	{
		if(fr[x][i] && !vis[i])
		{
			vis[i] = true;
			if(f[i] == -1)
			{
				f[i] = x;
				return true;
			}
			else if(find(f[i]))
			{
				f[i] = x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	while(~scanf("%d%d",&n,&k))
	{
		memset(f,-1,sizeof(f));
		memset(fr,false,sizeof(fr));
		for(int i = 1;i <= k;i++)
		{
			int x,y;
			scanf("%d%d",&x,&y);
			fr[x][y] = true;
		}
		int ans = 0;
		for(int i = 1; i <= n; i++)
		{
			memset(vis,false,sizeof(vis));
			if(find(i))
			 	ans++;
		}
		printf("%d\n",ans);
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章