【hdu 1068 Girls and Boys 最大獨立集數 匈牙利算法 】

點擊打開鏈接


Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12148    Accepted Submission(s): 5724


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std; 
int fr[511][511];//A和B是否有關係 
int f[511];//匹配情況 
int vis[511];
int n;
bool find(int x)
{
	for(int i = 0; i < n; i++)
	{
		if(fr[x][i] && !vis[i])
		{
			vis[i] = 1;
			if(f[i] == -1 || find(f[i]))
			{
				f[i] = x;
				return true;
			}
		}
	}
	return false;
}
int main()
{
	int T,t,a,b,ans;//a有b個關係 
	while(~scanf("%d",&T))
	{
		n = T;
		memset(fr,0,sizeof(fr));
		memset(f,-1,sizeof(f));
		for(int i = 0; i < T; i++)
		{
			scanf("%d: (%d)",&a,&b);
			for(int j = 0; j < b; j++)
			{
				scanf("%d",&t);
				fr[a][t] = 1;
				fr[t][a] = 1;
			}
		}
		ans=0;
		for(int i =  0; i < n; i++)
		{
			memset(vis,0,sizeof(vis));
			if(find(i))
				ans++;
		}
		ans = n - (ans / 2);//頂點數-最大配對數=最大獨立集數(因爲把集合擴大了一倍,所以除以二) 
		printf("%d\n",ans);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章